Subscribe to updates
Powered by
Partial service disruption
Resolved
·
Partial outage
This incident is resolved.
Thu, Oct 11, 2018, 02:44 PM
(
7
years ago)
·
View all updates
Affected components
Oct 11, 2018, 01:24 PM
02:44 PM
ClickUp Platform
Updates
Resolved
This incident is resolved.
Thu, Oct 11, 2018, 02:44 PM
Investigating
Investigating connection issue
Thu, Oct 11, 2018, 01:24 PM
(
1
hour earlier)
Partial service disruption - ClickUp Worldwide Status