Subscribe to updates
Powered by
Partial service disruption
Resolved
·
Partial outage
This incident is resolved.
Tue, Aug 28, 2018, 05:14 AM
(
8
years ago)
·
View all updates
Affected components
Aug 28, 2018, 05:13 AM
05:14 AM
ClickUp Platform
Updates
Resolved
This incident is resolved.
Tue, Aug 28, 2018, 05:14 AM
Investigating
Investigating connection issue
Tue, Aug 28, 2018, 05:13 AM
Partial service disruption - ClickUp Worldwide Status